Cómo instalar linset en Kali Linux 2.0

Para los que no la sepan, es una herramienta de ingeniería social, basada en el MITM para comprobar la seguridad (o ignorancia) de los clientes de nuestra red. Los pasos que realiza son:

FUNCIONAMIENTO

  1. Escanea la red.

  2. Selecciona la red.

  3. Busca handshake (se puede usar sin handshake)

  4. Se elige una de las varias interfaces web adaptadas por mi (gracias a la colaboración de los users)

  5. Se monta un FakeAP imitando al original

  6. Se crea un servidor DHCP sobre el FakeAP

  7. Se crea un servidor DNS para redirigir todas las peticiones al Host

  8. Se lanza el servidor web con la interface seleccionada

  9. Se lanza el mecanismo para comprobar la validez de las contraseñas que se van a introducir

  10. Se des autentifica a todos los usuarios de la red, esperando que se conecten al FakeAP e introduzcan la contraseña.

  11. Se detiene el ataque tras la comprobación correcta de la contraseña

     

Te preguntaras como descargar Linset?

Abres la terminal y colocas lo siguiente.

cd Desktop

git clone https://github.com/creadpag/linset.git

Se te apareceré una carpeta llamada ‘Linset’ sigues en la terminal.

cd linset

$ chmod +x linset
$ ./linset

y se te aparece algunos errores.

Screenshot from 2015-10-31 16:35:31

esos errores te muestra porque tienes que instalar todas esas herramienta que falta.

Instala las herramientas:

apt-get install isc-dhcp-server

apt-get install Php5-cgi

apt-get install Hostapd

apt-get install Lighttpd

Termino de instalar las 4 herramientas que faltaba.

Luego podrán ejecutar Linset.

Screenshot from 2015-10-31 17:10:50

 

Para las personas que tienen errores con esta herramienta se recomienda colocar los siguientes repositorio.
leafpad /etc/apt/sources.list
 

deb http://ftp.de.debian.org/debian testing main contrib non-free
deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free

Recuerda solo apt-get update. NO apt-get upgrade.
Al actualizar podemos instalar todas las herramientas que nos muestra error en caso que no reconozca su red inalambrica solo descarga y descomprime manualmente no lo hagas por la terminal.
No te olvides de sacar la repo después de la instalación.

Las Herramientas son:
apt-get install isc-dhcp-server
apt-get install hostapd
apt-get install lighttpd
apt-get install php5-cgi
En la 2016.1 todo es minuscula.
Tienes mas opciones al presionar control y click

52 pensamientos en “Cómo instalar linset en Kali Linux 2.0

  1. root@kali:~/linset# apt-get install Php5-cgi
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Suggested packages:
    php-pear
    The following NEW packages will be installed:
    php5-cgi
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 4,276 kB of archives.
    After this operation, 18.0 MB of additional disk space will be used.
    Err http://security.kali.org/kali-security/ sana/updates/main php5-cgi amd64 5.6.9+dfsg-0+deb8u1
    404 Not Found
    E: Failed to fetch http://security.kali.org/kali-security/pool/main/p/php5/php5-cgi_5.6.9+dfsg-0+deb8u1_amd64.deb 404 Not Found

    E: Unable to fetch some archives, maybe run apt-get update or try with –fix-missing?

    oye disculpa, tuve un problema en esto ahora como resuelvo esto? gracias!

    Me gusta

  2. ami me falla el lighttpd aparece esto

    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package lighttpd is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package ‘lighttpd’ has no installation candidate

    ya esta actualizado todo entonces en que fallo?

    Me gusta

      • sigue apareciendo error y es el unico que me falta por instalar

        Reading package lists… Done
        Building dependency tree
        Reading state information… Done
        The following extra packages will be installed:
        libfam0 libssl1.0.2 libterm-readline-perl-perl spawn-fcgi
        Suggested packages:
        fam rrdtool
        The following NEW packages will be installed:
        libfam0 libssl1.0.2 libterm-readline-perl-perl lighttpd spawn-fcgi
        0 upgraded, 5 newly installed, 0 to remove and 1923 not upgraded.
        E: Could not get lock /var/cache/apt/archives/lock – open (11: Resource temporarily unavailable)
        E: Unable to lock directory /var/cache/apt/archives/

        es lo que aparece y esta actualizado y ya le hice el upgrade

        Me gusta

      • y despues del update y upgrade aparece esto al final

        E: Could not get lock /var/cache/apt/archives/lock – open (11: Resource temporarily unavailable)
        E: Unable to lock directory /var/cache/apt/archives/

        Me gusta

      • ya lo solucione,eso me pasa por no questionar donde consigo esos repo,lo que hice fue conseguir otros repos que no eran para la instalacion que me faltaba,y como estaba corriendo lo pare,despues lo puse instalar y si corrio(agregando tus repo que me recomendaste)gracias,

        Me gusta

  3. Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    The following extra packages will be installed:
    libfam0 libssl1.0.2 libterm-readline-perl-perl spawn-fcgi
    Suggested packages:
    fam rrdtool
    The following NEW packages will be installed:
    libfam0 libssl1.0.2 libterm-readline-perl-perl lighttpd spawn-fcgi
    0 upgraded, 5 newly installed, 0 to remove and 1923 not upgraded.
    E: Could not get lock /var/cache/apt/archives/lock – open (11: Resource temporarily unavailable)
    E: Unable to lock directory /var/cache/apt/archives/

    es lo que aparece
    hmmm creo que tendre que moverle al sources.list

    Me gusta

  4. Hola, gracias por la informacion, la cual califico de excelente, he seguido todos los pasos para instalar linset en kali 2, todo sale bien actualizando linset, entonces habre y aparece la version 38 y despues al ponerse y detectar la auto resolucion , a continuacion me dice ,” no se han encontrado tarjetas wireless”, eso no entiendo ya que tengo mi amplificador wireless rt8187 ya conectado a la maquina virtual he incluso tengo la maquina virtual conectada al interned.
    La pregunta es, se necesitan para el programa de linset dos tarjetas wireless o no.
    gracias.
    renan

    Me gusta

  5. Hola buenas,
    Llevo varios días intentando solucionar esto:
    E: No se ha podido localizar el paquete isc-dhcp-server

    No consigo instalar ninguna de las 4 herramientas que faltan.

    Os agradecería mucho la ayuda plsss

    Me gusta

  6. /home/hanster/Pictures/screenshots/screenshot-window-2016-05-10-194007.png
    hola me sale que el Mdk3, Nmap y Xtern no installed, me podrias dar una solucion?

    Me gusta

  7. Hola porque despues de lanzar un ataque se bloquea mi targeta wifi de mi laptop y me deja sin internet ,como hago para contrarestarlo existe algun comando???

    Me gusta

  8. Hey amigo ya tengo el linset con todas sus herramientas, solo me pasa que al querer ejecutar una acción por ejemplo donde coloco el número 1 para que sea con handeshesck (o como se escriba) me reinicia Kali, no me deja avanzar solo se reinicia Kali y cierra todo, alguna solución??

    Me gusta

  9. Hola, el sistema me anda barbaro. Pero no me crea el dhcp para el fake ap. O sae, me abren todas las terminales, desconecto a los demas, creo mi wifi fake, pero la terminal que se llama dhcp nunca me abre. Que hago ? gracias desde ya

    Me gusta

  10. Saludos. tengo el clasico error .. obiamente ya dirige al repositorio de linux y agrege lo que se detallo en el blog pero aun ai me sale.

    error 404
    E: unable to fetch some archives, maybe run apt- get update or try…..

    y al darle apt-get update

    salen los errores:

    w: failet to fetch ://security.kali.org/kali-segurity ….. 404 not found

    W: some index files failed to downland. they have been ingnored, or old ones used instead.

    porfavor una pqña orientacion

    Me gusta

  11. Saludos, antes que todo quería felicitarlo por su blog me ha sido de muchísima ayuda y he aprendido mucho, le quiero solicitar su ayuda, he querido utilizar linset en kali linux 2016.1, pero no he podido instalar php5-cgi , porque me dice
    Package php5-cgi is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package ‘php5-cgi ’ has no installation candidate.
    Intente agregando los repositorios.
    deb http://ftp.de.debian.org/debian testing main contrib non-free
    deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free
    deb http://security.debian.org/ jessie/updates main contrib non-free

    Pero me dice que tengo paquetes rotos. y ya no se como hacer hago apt-get -f install, alguna solucion que me puedas recomendar

    Me gusta

  12. buenas, tengo el kali linux 2016.2 y el problema que tengo es el siguiente: root@kali:~# apt-get install Hostapd
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se ha podido localizar el paquete Hostapd

    Con este y con cualquier paquete que intente instalar, te he escrito en el face por que no se donde preguntarte. gracias

    Me gusta

  13. Tengo un error, ¿qué hago?
    root@Kali:~# apt-get install php5-cgi
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    php5-cgi : Depends: php5-cli but it is not going to be installed
    Depends: php5-json but it is not installable
    E: Unable to correct problems, you have held broken packages.

    Me gusta

    • The following packages have unmet dependencies:
      php5-cgi : Depends: php5-cli but it is not going to be installed
      Depends: php5-json but it is not installable
      E: Unable to correct problems, you have held broken packages.

      Me gusta

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s